Rackspace PDR Agent compatibility

  • Last updated on: 2019-03-08
  • Authored by: Nick Shobe

Our agents support the operating systems (OS) listed on this page. When building or upgrading servers, be sure to check this list first so that your systems will remain in support by Rackspace PDR. If you are unsure if an OS release or kernel version is supported, contact the Rackspace PDR support team.

Linux Agent Compatibility

Linux kernel strings on this page must match your kernel version exactly to be considered in support. If the kernel is unsupported, agents go into reduced functionality mode and no longer provide adaquate telemetry to our Security Operations Center (SOC).

Amazon Linux 2 Supported Versions

       
4.14.47-64.38.amzn2.x86_64 4.14.51-66.38.amzn2.x86_64 4.14.55-68.37.amzn2.x86_64 4.14.59-68.43.amzn2.x86_64
4.14.62-70.117.amzn2.x86_64 4.14.67-71.56.amzn2.x86_64 4.14.70-72.55.amzn2.x86_64 4.14.72-73.55.amzn2.x86_64
4.14.77-80.57.amzn2.x86_64 4.14.77-81.59.amzn2.x86_64 4.14.77-86.82.amzn2.x86_64 4.14.88-88.73.amzn2.x86_64
4.14.88-88.76.amzn2.x86_64 4.14.94-89.73.amzn2.x86_64 4.14.97-90.72.amzn2.x86_64  

Amazon Linux 2017.03 Supported Versions

       
4.9.17-8.31.amzn1.x86_64 4.9.20-10.30.amzn1.x86_64 4.9.20-11.31.amzn1.x86_64 4.9.27-14.31.amzn1.x86_64
4.9.27-14.33.amzn1.x86_64 4.9.32-15.41.amzn1.x86_64 4.9.38-16.33.amzn1.x86_64 4.9.38-16.35.amzn1.x86_64
4.9.43-17.38.amzn1.x86_64 4.9.43-17.39.amzn1.x86_64 4.9.51-10.52.amzn1.x86_64 4.9.70-25.242.amzn1.x86_64
4.9.75-25.55.amzn1.x86_64      

Amazon Linux 2017.09 Supported Versions

       
4.9.116-43.59.amzn1.x86_64 4.9.119-44.140.amzn1.x86_64 4.9.58-18.51.amzn1.x86_64 4.9.58-18.55.amzn1.x86_64
4.9.62-21.56.amzn1.x86_64 4.9.70-22.55.amzn1.x86_64 4.9.76-3.78.amzn1.x86_64 4.9.77-31.58.amzn1.x86_64
4.9.81-35.56.amzn1.x86_64 4.9.85-37.55.amzn1.x86_64 4.9.85-38.58.amzn1.x86_64 4.9.93-41.60.amzn1.x86_64

Amazon Linux 2018.03 Supported Versions

       
4.14.26-46.32.amzn1.x86_64 4.14.33-51.34.amzn1.x86_64 4.14.33-51.37.amzn1.x86_64 4.14.42-52.37.amzn1.x86_64
4.14.47-56.37.amzn1.x86_64 4.14.51-60.37.amzn1.x86_64 4.14.51-60.38.amzn1.x86_64 4.14.59-64.43.amzn1.x86_64
4.14.62-65.117.amzn1.x86_64 4.14.67-66.56.amzn1.x86_64 4.14.70-67.55.amzn1.x86_64 4.14.72-68.55.amzn1.x86_64
4.14.77-69.57.amzn1.x86_64 4.14.77-70.59.amzn1.x86_64 4.14.77-70.82.amzn1.x86_64 4.14.88-72.73.amzn1.x86_64
4.14.88-72.76.amzn1.x86_64 4.14.94-73.73.amzn1.x86_64 4.14.97-74.72.amzn1.x86_64  

RHEL 6 / CentOS 6 Supported Versions

       
2.6.32-573.1.1.el6.x86_64 2.6.32-573.12.1.el6.x86_64 2.6.32-573.18.1.el6.x86_64 2.6.32-573.22.1.el6.x86_64
2.6.32-573.26.1.el6.x86_64 2.6.32-573.3.1.el6.x86_64 2.6.32-573.30.1.el6.x86_64 2.6.32-573.32.1.el6.x86_64
2.6.32-573.34.1.el6.x86_64 2.6.32-573.35.1.el6.x86_64 2.6.32-573.35.2.el6.x86_64 2.6.32-573.37.1.el6.x86_64
2.6.32-573.38.1.el6.x86_64 2.6.32-573.40.1.el6.x86_64 2.6.32-573.41.1.el6.x86_64 2.6.32-573.42.1.el6.x86_64
2.6.32-573.42.2.el6.x86_64 2.6.32-573.43.2.el6.x86_64 2.6.32-573.43.3.el6.x86_64 2.6.32-573.45.1.el6.x86_64
2.6.32-573.45.2.el6.x86_64 2.6.32-573.47.1.el6.x86_64 2.6.32-573.48.1.el6.x86_64 2.6.32-573.49.1.el6.x86_64
2.6.32-573.49.3.el6.x86_64 2.6.32-573.51.1.el6.x86_64 2.6.32-573.53.1.el6.x86_64 2.6.32-573.55.2.el6.x86_64
2.6.32-573.55.4.el6.x86_64 2.6.32-573.59.1.el6.x86_64 2.6.32-573.60.1.el6.x86_64 2.6.32-573.60.4.el6.x86_64
2.6.32-573.62.1.el6.x86_64 2.6.32-573.65.2.el6.x86_64 2.6.32-573.7.1.el6.x86_64 2.6.32-573.8.1.el6.x86_64
2.6.32-573.el6.x86_64 2.6.32-642.1.1.el6.x86_64 2.6.32-642.11.1.el6.x86_64 2.6.32-642.13.1.el6.x86_64
2.6.32-642.13.2.el6.x86_64 2.6.32-642.15.1.el6.x86_64 2.6.32-642.3.1.el6.x86_64 2.6.32-642.4.2.el6.x86_64
2.6.32-642.6.1.el6.x86_64 2.6.32-642.6.2.el6.x86_64 2.6.32-642.el6.x86_64 2.6.32-696.1.1.el6.x86_64
2.6.32-696.10.1.el6.x86_64 2.6.32-696.10.2.el6.x86_64 2.6.32-696.10.3.el6.x86_64 2.6.32-696.13.2.el6.x86_64
2.6.32-696.16.1.el6.x86_64 2.6.32-696.18.7.el6.x86_64 2.6.32-696.20.1.el6.x86_64 2.6.32-696.23.1.el6.x86_64
2.6.32-696.28.1.el6.x86_64 2.6.32-696.3.1.el6.x86_64 2.6.32-696.3.2.el6.x86_64 2.6.32-696.30.1.el6.x86_64
2.6.32-696.6.3.el6.x86_64 2.6.32-696.el6.x86_64 2.6.32-754.10.1.el6.x86_64 2.6.32-754.2.1.el6.x86_64
2.6.32-754.3.5.el6.x86_64 2.6.32-754.6.3.el6.x86_64 2.6.32-754.9.1.el6.x86_64 2.6.32-754.el6.x86_64

RHEL 7 / CentOS 7 Supported Versions

       
3.10.0-229.1.2.el7.x86_64 3.10.0-229.11.1.el7.x86_64 3.10.0-229.14.1.el7.x86_64 3.10.0-229.20.1.el7.x86_64
3.10.0-229.24.2.el7.x86_64 3.10.0-229.26.2.el7.x86_64 3.10.0-229.28.1.el7.x86_64 3.10.0-229.30.1.el7.x86_64
3.10.0-229.34.1.el7.x86_64 3.10.0-229.38.1.el7.x86_64 3.10.0-229.4.2.el7.x86_64 3.10.0-229.40.1.el7.x86_64
3.10.0-229.42.1.el7.x86_64 3.10.0-229.42.2.el7.x86_64 3.10.0-229.44.1.el7.x86_64 3.10.0-229.46.1.el7.x86_64
3.10.0-229.48.1.el7.x86_64 3.10.0-229.49.1.el7.x86_64 3.10.0-229.7.2.el7.x86_64 3.10.0-229.el7.x86_64
3.10.0-327.10.1.el7.x86_64 3.10.0-327.13.1.el7.x86_64 3.10.0-327.18.2.el7.x86_64 3.10.0-327.22.2.el7.x86_64
3.10.0-327.28.2.el7.x86_64 3.10.0-327.28.3.el7.x86_64 3.10.0-327.3.1.el7.x86_64 3.10.0-327.36.1.el7.x86_64
3.10.0-327.36.2.el7.x86_64 3.10.0-327.36.3.el7.x86_64 3.10.0-327.4.4.el7.x86_64 3.10.0-327.4.5.el7.x86_64
3.10.0-327.41.3.el7.x86_64 3.10.0-327.41.4.el7.x86_64 3.10.0-327.44.2.el7.x86_64 3.10.0-327.46.1.el7.x86_64
3.10.0-327.49.2.el7.x86_64 3.10.0-327.53.1.el7.x86_64 3.10.0-327.55.1.el7.x86_64 3.10.0-327.55.2.el7.x86_64
3.10.0-327.55.3.el7.x86_64 3.10.0-327.58.1.el7.x86_64 3.10.0-327.59.1.el7.x86_64 3.10.0-327.59.2.el7.x86_64
3.10.0-327.59.3.el7.x86_64 3.10.0-327.61.3.el7.x86_64 3.10.0-327.62.1.el7.x86_64 3.10.0-327.el7.x86_64
3.10.0-514.10.2.el7.x86_64 3.10.0-514.16.1.el7.x86_64 3.10.0-514.2.2.el7.x86_64 3.10.0-514.21.1.el7.x86_64
3.10.0-514.21.2.el7.x86_64 3.10.0-514.26.1.el7.x86_64 3.10.0-514.26.2.el7.x86_64 3.10.0-514.28.1.el7.x86_64
3.10.0-514.28.2.el7.x86_64 3.10.0-514.32.2.el7.x86_64 3.10.0-514.32.3.el7.x86_64 3.10.0-514.35.1.el7.x86_64
3.10.0-514.35.1.el7.x86_64 3.10.0-514.36.1.el7.x86_64 3.10.0-514.36.5.el7.x86_64 3.10.0-514.41.1.el7.x86_64
3.10.0-514.44.1.el7.x86_64 3.10.0-514.48.1.el7.x86_64 3.10.0-514.48.3.el7.x86_64 3.10.0-514.48.5.el7.x86_64
3.10.0-514.51.1.el7.x86_64 3.10.0-514.53.1.el7.x86_64 3.10.0-514.55.4.el7.x86_64 3.10.0-514.58.1.el7.x86_64
3.10.0-514.6.1.el7.x86_64 3.10.0-514.6.2.el7.x86_64 3.10.0-514.61.1.el7.x86_64 3.10.0-514.el7.x86_64
3.10.0-693.1.1.el7.x86_64 3.10.0-693.11.1.el7.x86_64 3.10.0-693.11.6.el7.x86_64 3.10.0-693.17.1.el7.x86_64
3.10.0-693.2.1.el7.x86_64 3.10.0-693.2.2.el7.x86_64 3.10.0-693.21.1.el7.x86_64 3.10.0-693.25.2.el7.x86_64
3.10.0-693.25.4.el7.x86_64 3.10.0-693.25.7.el7.x86_64 3.10.0-693.33.1.el7.x86_64 3.10.0-693.35.1.el7.x86_64
3.10.0-693.37.4.el7.x86_64 3.10.0-693.39.1.el7.x86_64 3.10.0-693.43.1.el7.x86_64 3.10.0-693.44.1.el7.x86_64
3.10.0-693.5.2.el7.x86_64 3.10.0-693.el7.x86_64 3.10.0-862.11.6.el7.x86_64 3.10.0-862.14.4.el7.x86_64
3.10.0-862.2.3.el7.x86_64 3.10.0-862.20.2.el7.x86_64 3.10.0-862.25.3.el7.x86_64 3.10.0-862.27.1.el7.x86_64
3.10.0-862.3.2.el7.x86_64 3.10.0-862.3.3.el7.x86_64 3.10.0-862.9.1.el7.x86_64 3.10.0-862.el7.x86_64
3.10.0-957.1.3.el7.x86_64 3.10.0-957.5.1.el7.x86_64 3.10.0-957.el7.x86_64  

Ubuntu 14.04LTS Supported Versions

       
3.13.0-100-generic 3.13.0-101-generic 3.13.0-103-generic 3.13.0-105-generic
3.13.0-106-generic 3.13.0-107-generic 3.13.0-108-generic 3.13.0-109-generic
3.13.0-110-generic 3.13.0-112-generic 3.13.0-113-generic 3.13.0-115-generic
3.13.0-116-generic 3.13.0-117-generic 3.13.0-119-generic 3.13.0-121-generic
3.13.0-123-generic 3.13.0-125-generic 3.13.0-126-generic 3.13.0-128-generic
3.13.0-129-generic 3.13.0-132-generic 3.13.0-133-generic 3.13.0-135-generic
3.13.0-137-generic 3.13.0-139-generic 3.13.0-141-generic 3.13.0-142-generic
3.13.0-143-generic 3.13.0-145-generic 3.13.0-147-generic 3.13.0-149-generic
3.13.0-151-generic 3.13.0-153-generic 3.13.0-155-generic 3.13.0-156-generic
3.13.0-157-generic 3.13.0-158-generic 3.13.0-160-generic 3.13.0-161-generic
3.13.0-162-generic 3.13.0-163-generic 3.13.0-164-generic 3.13.0-165-generic
3.13.0-24-generic 3.13.0-27-generic 3.13.0-29-generic 3.13.0-30-generic
3.13.0-32-generic 3.13.0-33-generic 3.13.0-34-generic 3.13.0-35-generic
3.13.0-36-generic 3.13.0-37-generic 3.13.0-39-generic 3.13.0-40-generic
3.13.0-41-generic 3.13.0-43-generic 3.13.0-44-generic 3.13.0-45-generic
3.13.0-46-generic 3.13.0-48-generic 3.13.0-49-generic 3.13.0-51-generic
3.13.0-52-generic 3.13.0-53-generic 3.13.0-54-generic 3.13.0-55-generic
3.13.0-57-generic 3.13.0-58-generic 3.13.0-59-generic 3.13.0-61-generic
3.13.0-62-generic 3.13.0-63-generic 3.13.0-65-generic 3.13.0-66-generic
3.13.0-67-generic 3.13.0-68-generic 3.13.0-70-generic 3.13.0-71-generic
3.13.0-73-generic 3.13.0-74-generic 3.13.0-76-generic 3.13.0-77-generic
3.13.0-79-generic 3.13.0-83-generic 3.13.0-85-generic 3.13.0-86-generic
3.13.0-87-generic 3.13.0-88-generic 3.13.0-91-generic 3.13.0-92-generic
3.13.0-93-generic 3.13.0-95-generic 3.13.0-96-generic 3.13.0-98-generic
4.4.0-101-generic 4.4.0-103-generic 4.4.0-104-generic 4.4.0-108-generic
4.4.0-109-generic 4.4.0-111-generic 4.4.0-112-generic 4.4.0-116-generic
4.4.0-121-generic 4.4.0-124-generic 4.4.0-127-generic 4.4.0-128-generic
4.4.0-130-generic 4.4.0-131-generic 4.4.0-133-generic 4.4.0-134-generic
4.4.0-135-generic 4.4.0-137-generic 4.4.0-138-generic 4.4.0-139-generic
4.4.0-140-generic 4.4.0-141-generic 4.4.0-142-generic 4.4.0-21-generic
4.4.0-22-generic 4.4.0-24-generic 4.4.0-28-generic 4.4.0-31-generic
4.4.0-34-generic 4.4.0-36-generic 4.4.0-38-generic 4.4.0-42-generic
4.4.0-45-generic 4.4.0-47-generic 4.4.0-51-generic 4.4.0-53-generic
4.4.0-57-generic 4.4.0-59-generic 4.4.0-62-generic 4.4.0-63-generic
4.4.0-64-generic 4.4.0-66-generic 4.4.0-67-generic 4.4.0-70-generic
4.4.0-71-generic 4.4.0-72-generic 4.4.0-75-generic 4.4.0-78-generic
4.4.0-79-generic 4.4.0-81-generic 4.4.0-83-generic 4.4.0-87-generic
4.4.0-89-generic 4.4.0-91-generic 4.4.0-92-generic 4.4.0-93-generic
4.4.0-96-generic 4.4.0-97-generic 4.4.0-98-generic  

Ubuntu 16.04.5 Supported Versions

       
4.15.0-13-generic 4.15.0-15-generic 4.15.0-20-generic 4.15.0-22-generic
4.15.0-23-generic 4.15.0-24-generic 4.15.0-29-generic 4.15.0-30-generic
4.15.0-32-generic 4.15.0-33-generic 4.15.0-34-generic 4.15.0-36-generic

Ubuntu 16.04LTS Supported Versions

       
4.15.0-1027-aws 4.15.0-38-generic 4.15.0-39-generic 4.15.0-42-generic
4.15.0-43-generic 4.15.0-45-generic 4.4.0-1001-aws 4.4.0-1003-aws
4.4.0-1004-aws 4.4.0-1007-aws 4.4.0-1009-aws 4.4.0-101-generic
4.4.0-1011-aws 4.4.0-1012-aws 4.4.0-1013-aws 4.4.0-1016-aws
4.4.0-1017-aws 4.4.0-1018-aws 4.4.0-1020-aws 4.4.0-1022-aws
4.4.0-1026-aws 4.4.0-1028-aws 4.4.0-103-generic 4.4.0-1030-aws
4.4.0-1031-aws 4.4.0-1032-aws 4.4.0-1035-aws 4.4.0-1037-aws
4.4.0-1038-aws 4.4.0-1039-aws 4.4.0-104-generic 4.4.0-1041-aws
4.4.0-1043-aws 4.4.0-1044-aws 4.4.0-1047-aws 4.4.0-1048-aws
4.4.0-1049-aws 4.4.0-1050-aws 4.4.0-1052-aws 4.4.0-1054-aws
4.4.0-1055-aws 4.4.0-1057-aws 4.4.0-1060-aws 4.4.0-1061-aws
4.4.0-1065-aws 4.4.0-1066-aws 4.4.0-1067-aws 4.4.0-1069-aws
4.4.0-1070-aws 4.4.0-1072-aws 4.4.0-1073-aws 4.4.0-1074-aws
4.4.0-1075-aws 4.4.0-108-generic 4.4.0-109-generic 4.4.0-112-generic
4.4.0-116-generic 4.4.0-119-generic 4.4.0-121-generic 4.4.0-122-generic
4.4.0-124-generic 4.4.0-127-generic 4.4.0-128-generic 4.4.0-130-aws
4.4.0-130-generic 4.4.0-131-aws 4.4.0-131-generic 4.4.0-133-generic
4.4.0-134-generic 4.4.0-135-generic 4.4.0-137-generic 4.4.0-138-generic
4.4.0-139-generic 4.4.0-140-generic 4.4.0-141-generic 4.4.0-142-generic
4.4.0-21-generic 4.4.0-22-generic 4.4.0-24-generic 4.4.0-28-generic
4.4.0-31-generic 4.4.0-34-generic 4.4.0-36-generic 4.4.0-38-generic
4.4.0-42-generic 4.4.0-43-generic 4.4.0-45-generic 4.4.0-47-generic
4.4.0-51-generic 4.4.0-53-generic 4.4.0-57-generic 4.4.0-59-generic
4.4.0-62-generic 4.4.0-63-generic 4.4.0-64-generic 4.4.0-66-generic
4.4.0-67-generic 4.4.0-70-generic 4.4.0-71-generic 4.4.0-72-generic
4.4.0-75-generic 4.4.0-77-generic 4.4.0-78-generic 4.4.0-79-generic
4.4.0-81-generic 4.4.0-83-generic 4.4.0-87-generic 4.4.0-89-generic
4.4.0-91-generic 4.4.0-92-generic 4.4.0-93-generic 4.4.0-96-generic
4.4.0-97-generic 4.4.0-98-generic    

Ubuntu 18.04 LTS Supported Versions

       
4.15.0-1007-aws 4.15.0-1009-aws 4.15.0-1010-aws 4.15.0-1011-aws
4.15.0-1016-aws 4.15.0-1017-aws 4.15.0-1019-aws 4.15.0-1020-aws
4.15.0-1021-aws 4.15.0-1023-aws 4.15.0-1025-aws 4.15.0-1029-aws
4.15.0-1031-aws 4.15.0-1032-aws 4.15.0-20-generic 4.15.0-22-generic
4.15.0-23-generic 4.15.0-24-generic 4.15.0-29-generic 4.15.0-30-generic
4.15.0-32-generic 4.15.0-33-generic 4.15.0-34-generic 4.15.0-36-generic
4.15.0-38-generic 4.15.0-39-generic 4.15.0-42-generic 4.15.0-43-generic
4.15.0-44-generic 4.15.0-45-generic    

Windows Agent Compatibility

Windows Server 2008 R2 SP1 Supported Versions

 
6.1.7601

Windows Server 2012 Supported Versions

 
6.2.9200

Windows Server 2012 R2 Supported Versions

 
6.3.9600

Windows Server 2016 Supported Versions

 
10.0.14393